Справочник функций

Ваш аккаунт

Войти через: 
Забыли пароль?
Регистрация
Информацию о новых материалах можно получать и без регистрации:

Почтовая рассылка

Подписчиков: -1
Последний выпуск: 19.06.2015

Версии библиотек Linux

4
23 января 2005 года
mike
3.7K / / 01.10.2002
Компилирую под одним линуксом, просит libstdc++.so.5, под другим - просит libstdc++.so.6

Как мне правильна написать в системных требованиях это ?

Я видел что пишут так:

Linux glibc-2.2 (i386) и выше

Как мне писать ?
1.7K
24 января 2005 года
Envel
206 / / 29.11.2004
Цитата:
Originally posted by mike
Компилирую под одним линуксом, просит libstdc++.so.5, под другим - просит libstdc++.so.6

Как мне правильна написать в системных требованиях это ?

Я видел что пишут так:

Linux glibc-2.2 (i386) и выше

Как мне писать ?


А не судьба зайти на rpm.pbone.net, набрать в строке поиска libstdc++.so.6 и посмотреть в каких пакетах он лежит? По-моему, версия пакета libstdc++ как раз должна совпадать с версией glibc.

4
24 января 2005 года
mike
3.7K / / 01.10.2002
Цитата:
Originally posted by Envel

А не судьба зайти на rpm.pbone.net, набрать в строке поиска libstdc++.so.6 и посмотреть в каких пакетах он лежит? По-моему, версия пакета libstdc++ как раз должна совпадать с версией glibc.



Да там не понятно.
Не совпадает.

Вот что я установил опытным путем:

libstdc++.so.6:

SuSE Linux 7.3 (2.4.10, glibc 2.2.4)
SuSE Linux 9.0 (2.4.21, glibc 2.3.2)
SuSE Linux 9.2
Debian Linux 3.0 (2.2.20, glibc 2.2.5)

libstdc++.so.5:

GNU/Linux (2.4.10, glibc 2.3.3)

1.7K
24 января 2005 года
Envel
206 / / 29.11.2004
Цитата:
Originally posted by mike


Да там не понятно.
Не совпадает.

Вот что я установил опытным путем:

libstdc++.so.6:

SuSE Linux 7.3 (2.4.10, glibc 2.2.4)
SuSE Linux 9.0 (2.4.21, glibc 2.3.2)
SuSE Linux 9.2
Debian Linux 3.0 (2.2.20, glibc 2.2.5)

libstdc++.so.5:

GNU/Linux (2.4.10, glibc 2.3.3)


libstdc++ обычно отдельным пакетом идет для многих дистрибутивов (например, у меня в MDK10.1 это так). Так что, накладывайте ограничение на libstdc++ или пишите для каждого дистрибутива, в которых она с glibc, номер версии.

Знаете кого-то, кто может ответить? Поделитесь с ним ссылкой.

Ваш ответ

Реклама на сайте | Обмен ссылками | Ссылки | Экспорт (RSS) | Контакты
Добавить статью | Добавить исходник | Добавить хостинг-провайдера | Добавить сайт в каталог