Справочник функций

Ваш аккаунт

Войти через: 
Забыли пароль?
Регистрация
Информацию о новых материалах можно получать и без регистрации:

Почтовая рассылка

Подписчиков: -1
Последний выпуск: 19.06.2015

openSUSE 10.3 + ATI Radeon HD2600 Pro AGP. Как распинать 3D?

92
11 января 2008 года
Тень Пса
2.2K / / 19.10.2006
В Общем, собственно сабж. где я только не искал, чего я только не пробовал, но никакие ATI драйвера не понимают мою видюху.

Работать-то она работает, но 3D не поддерживает... мне кажется это не менее, чем странным )

Читал на форумах, что даже под Win. эту видюху распинать сложно. я распинал, но на половине игр (запускал для теста) вылетает в синий экран с ругательствами на драйвер, еще часть не хочет стартовать в принципе, а другие работают нормально.

под openSUSE 10.3 всё тоже плохо - если я ставлю оконным менеджером Xgl (как советуют делать для ATI, на сайте openSUSE) и пытаюсь запустить Compiz, то всё получается плохо - всё жутко тормозит (скроллинг в браузере на 1-2 строчки вниз занимает около 20 секунд, и я вижу как перерисовывается каждый кадр).

если же я ставлю оконным менеджером Xorg (+ драйвер "fglrx" в xorg.cong), то тормозит не всё. Но ведь с таким монстром (по сравнению с моей старой видюхой Radeon 9600SE 128 mb) думал можно и на двух гранях куба Compiz смотреть пару фильмов и не напрягаться, например.

Ставил разные дрова и самые новые, и те что прям вот для серии 2400-2600 (так пишет ATI на своем сайте в списке пакетов) - толку нет.

подскажите, как мне распинать всё это дело на поддержку 3D и на полное использование ресурсов видеокарты? всё таки не 16 мегабайтная бортовая :(

[SIZE=1]ЗЫ: на форумах, говорят что именно с AGP версией этой карточки заморочки. потому как даже под Windows приходилось качать какие-то мегадрова в 200 с лишним метров.
[/SIZE]
2
11 января 2008 года
squirL
5.6K / / 13.08.2003
боюсь, что никак. поддержка ATI - слабое место Linux. или скорее так - ATI забило на Linux и не пишет человеческих дров.
ЗЫ: уж сколько раз твердили миру - подбирайте железо под UNIX/Linux по HCL. это не винда, под которую каждый второй китаец пишет дрова.
92
11 января 2008 года
Тень Пса
2.2K / / 19.10.2006
извини конечно, но пожалуй железо мне чётко под Linux/UNIX подбирать не приходилось :) мне приходилось брать железяки помощнее (те что давали) ) а эту видюху просто подарили :)

эх... "никак" звучит не ободряюще ( жаль... очень жаль...

но спасибо за ответ :)
2
11 января 2008 года
squirL
5.6K / / 13.08.2003
Цитата: Тень Пса
извини конечно, но пожалуй железо мне чётко под Linux/UNIX подбирать не приходилось :)


да это не в упрек тебе. это просто констатация факта :) перед тем как использовать Линукс или Уникс (тем паче коммерческий) желательно изучить HCL. это при покупке.. но раз подарили... ;)

92
11 января 2008 года
Тень Пса
2.2K / / 19.10.2006
да я тож отшутился ;) в общем, если получится распинать... тем более, что саппорт ATI пошёл на контакт, выложу решение ) но! это если получится :)

ЗЫ: это будет всяко не раньше, чем на след. неделе.... отдыхать надо :(

всем удачи! (не берите ATI видюхи :D)
552
11 января 2008 года
Ivanhoe
373 / / 30.04.2006
Они теперь открыли все спеки на свои железки и юниксоиды-атишники стали абсолютно счастливы :)
63
12 января 2008 года
Zorkus
2.6K / / 04.11.2006
Да нет, я атишными дровами вполне доволен.
Под Fedora 8 c ливновскими дровами у меня для Radeon X1650 работает все вполне прилично (никакой порнухи в браузере вроде покадровой анимации не наблюдается), glxgears в консоли 6000 FPS устойчиво держит.
2
12 января 2008 года
squirL
5.6K / / 13.08.2003
Цитата: Ivanhoe
Они теперь открыли все спеки на свои железки и юниксоиды-атишники стали абсолютно счастливы :)



все эти спеки - до одного места. мне лично нафиг не надо открытые дрова. мне нужны - хорошие дрова. закрытые от nvidia - всегда работали на 5+. что еще надо? закрытые от АТИ - фуфло. а пока по спекам напишут что-то приличное (если напишут) - рак свистнет где то...

92
15 января 2008 года
Тень Пса
2.2K / / 19.10.2006
ага. вставил Radeon 9600 SE, пашет драйвер закрытый ATIшный. на 5+ )))))
а для Radeon HD2600 Pro, нужен соотвессна radeonhd драйвер ))) или fglrx (что виснет намертво при старте X'ов).
таак, а radeonhd пишется хз кем, и вывешивается на x.org..... в общем фуфло. )))

короче, я сдаюсь, иду с зарплаты покупать NVidia ))) только проблема в том, что у меня еще AGP ) и что-то новое получится ли купить? )

2 Zorkus: возможно у тебя видушка просто из списка man radeon 4 :) если да, то тебе повезло :)
5
15 января 2008 года
hardcase
4.5K / / 09.08.2005
На Убунту 7.10 ставил проприетарные драйвера АТИ (по википедии). Видеокарта Radeon HD 2600 Pro на PCI-E.
92
15 января 2008 года
Тень Пса
2.2K / / 19.10.2006
про PCI-E не идёт речи =)) с ней под вынь тож нету проблем ))) а эту (та что AGP) я пытался и в вынь распинать =) - результат в первом посте.

Цитата:

Читал на форумах, что даже под Win. эту видюху распинать сложно. я распинал, но на половине игр (запускал для теста) вылетает в синий экран с ругательствами на драйвер, еще часть не хочет стартовать в принципе, а другие работают нормально.




PS: у товарища то же самое на PCI-E и ничего, работает ) с проприетарным драйвером... хз, мож АТИ сказал что мы больше не будем поддерживать AGP видюхи? :)

Знаете кого-то, кто может ответить? Поделитесь с ним ссылкой.

Ваш ответ

Реклама на сайте | Обмен ссылками | Ссылки | Экспорт (RSS) | Контакты
Добавить статью | Добавить исходник | Добавить хостинг-провайдера | Добавить сайт в каталог