Справочник функций

Ваш аккаунт

Войти через: 
Забыли пароль?
Регистрация
Информацию о новых материалах можно получать и без регистрации:

Почтовая рассылка

Подписчиков: -1
Последний выпуск: 19.06.2015

Перевести логическую формулу в макрос, Excel

34K
19 мая 2012 года
Лунатик
5 / / 06.02.2008
Ребят помогите пожалуйста вот эту формулу представить в виде скрипта:
=ЕСЛИ(E3="";B3-B3;ЕСЛИ(B3>E3;B3-E3;0))

Пробовал так:
 
Код:
Range("G3").Select
ActiveCell.FormulaLocal = "=Если(E3="";B3-B3;Если(B3>E3;B3-E3;0))"
Но, судя по всему, данная процедура справедлива только для математических формул, а для логических - нет. :(

Буду премного благодарен. :)
34K
19 мая 2012 года
Лунатик
5 / / 06.02.2008
Вопрос решен следующим способом:
 
Код:
Range("G3").FormulaLocal = "=Если(E3="""";B3-B3;Если(B3>E3;B3-E3;0))"
34K
19 мая 2012 года
Лунатик
5 / / 06.02.2008
Мне бы теперь другое подсказать.
Вот выполнилась операция, а теперь нужно сделать тоже самое еще раз и так столько раз пока значение в некоторой ячейки не будет меньше, ну скажем 1000. Тогда этот цикл прекращается.

Вот это я точно не знаю как реализовать. :(

Знаете кого-то, кто может ответить? Поделитесь с ним ссылкой.

Ваш ответ

Реклама на сайте | Обмен ссылками | Ссылки | Экспорт (RSS) | Контакты
Добавить статью | Добавить исходник | Добавить хостинг-провайдера | Добавить сайт в каталог